Cannot Add Users to Groups Due to a Null Group Name

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

  1. User loses the ability to add users to specific groups. Whenever he clicks on the "Groups" link in the User Browser, it just says that the user is a member of all groups, even though they are not.

  2. Unable to delete an unnamed Group

Diagnosis

1 2 3 4 5 6 7 8 9 SELECT * FROM GROUPBASE WHERE GROUPNAME IS NULL +-------+-----------+ | ID | GROUPNAME | +-------+-----------+ | 12345 | (null) | +-------+-----------+

Cause

The GROUPBASE table has a NULL entry.

Solution

Resolution

  1. Run the following query against your database:

    1 2 3 SELECT * FROM GROUPBASE WHERE GROUPNAME IS NULL

    ℹ️ This should return a result with a null group

  1. Correct the faulty entry from you database using this query:

    1 2 3 4 UPDATE GROUPBASE SET GROUPNAME = 'name' WHERE GROUPNAME = <id>

Always perform a backup of your database before running queries against it.

Updated on April 8, 2025

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