Canned Responses Are No Longer Available

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

In Jira Service Management version 4.0.0, users cannot find canned responses, and the below error is thrown in the user interface:

We can't add canned response data to the search index right now. You could try again or contact your administrator

(Auto-migrated image: description temporarily unavailable)

Expected behavior

Users may find, select and edit canned responses.

Cause

Service Management does not properly close a Lucene search index.

This has been identified and fixed in JSDSERVER-6470 - Canned response error when trying to define/select a canned response.

Diagnosis steps

The log files may contain errors similar to those shown below:

2019-05-13 12:49:33,047 http-nio-8080-exec-519 WARN 769x169315x1 /rest/servicedesk/canned-responses/1/search/PROJECT [cannedresponses.internal.index.CannedResponseIndexManagerImpl] There was an error while searching for Canned Response : CannedResponseSear chParams{query=Optional.empty, userKey=Optional.empty, date=Optional.empty, cannedResponseSearchSubstitutionParams=Optional[CannedResponseSearchSubstitutionParams{issue=EXT-2111}], includeDisabled=false, serviceDesk=ServiceDeskImpl{serviceDeskId=3, projectId=10700, projectName=IRT Support, accessConfig=AccessConfig{p ublicSignUp=false, openAccess=false}, createdByUserKey=some(hont), createdDate=some(2018-10-23 07:48:04.688), createdWithEmptyProject=some(true), createdAtVersion=some(3.15.3-REL-0003), legacyCommentTransitionDisabled=true}, limitedPagedRequest=LimitedPagedRequestImpl{start=0, limit=5, maxLimit=500}} com.atlassian.servicedesk.plugins.cannedresponses.internal.lucene.search.CannedResponseSearcherImpl$CannedResponseSearchException: Error while performing Canned Response search at com.atlassian.servicedesk.plugins.cannedresponses.internal.lucene.search.CannedResponseSearcherImpl.lambda$search$2(CannedResponseSearcherImpl.java:63) ... 2019-05-13 12:49:33,056 http-nio-8080-exec-544 WARN 769x169316x1 /rest/servicedesk/canned-responses/1/search/PROJECT [internal.lucene.search.CannedResponseManagedIndexSearcherFactory] Unexpected exception during execution of canned response index searcher com.atlassian.jira.util.RuntimeIOException: org.apache.lucene.store.LockObtainFailedException: Lock held by this virtual machine: /var/atlassian/jira/caches/indexesV1/plugins/servicedeskcannedresponses/write.lock at com.atlassian.jira.index.WriterWrapper$1.get(WriterWrapper.java:66) ...

Resolution

This problem is fixed in the following Jira Service Management versions: 4.0.4, 4.1.3, 4.3.2, and 4.4.0 and greater.

The following workaround is available for customers using other versions of Jira Service Management:

  • Stop Jira.

  • Delete the file <Jira_HOME>/caches/indexesV1/plugins/servicedeskcannedresponses/write.lock.

  • Start Jira. Upon startup, the canned response index should be rebuilt.

If the problem persists, please reach out to Atlassian Support via https://support.atlassian.com/.

Updated on April 8, 2025

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