Canned Responses Are No Longer Available
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
In Jira Service Management version 4.0.0, users cannot find canned responses, and the below error is thrown in the user interface:
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Expected behavior
Users may find, select and edit canned responses.
Cause
Service Management does not properly close a Lucene search index.
This has been identified and fixed in JSDSERVER-6470 - Canned response error when trying to define/select a canned response.
Diagnosis steps
The log files may contain errors similar to those shown below:
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Resolution
This problem is fixed in the following Jira Service Management versions: 4.0.4, 4.1.3, 4.3.2, and 4.4.0 and greater.
The following workaround is available for customers using other versions of Jira Service Management:
Stop Jira.
Delete the file <Jira_HOME>/caches/indexesV1/plugins/servicedeskcannedresponses/write.lock.
Start Jira. Upon startup, the canned response index should be rebuilt.
If the problem persists, please reach out to Atlassian Support via https://support.atlassian.com/.
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