Canned Response button missing from the comment section

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When trying to comment on a Service Desk issue, the canned response button is missing from the top menu of the comment field:

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Expected behavior

The canned response button should be available in the top menu:

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Cause

This issue might happen due to either of the reasons below:

  1. You are running Service Desk on a version lower than 3.7.0

  2. The Service Desk Canned Response plugin is disabled in the Add-on management page

  3. The Canned Response functionality is disabled in the Dark Feature page

  4. The 3rd party add-on ScriptRunner for JIRA is causing the issue

  5. The rich text editor is currently disabled

Resolution

For Cause 1:

  • Upgrade Service Des to version 3.7.0 or later, since the canned response feature was introduced in this version, per the 3.7.x release notes.

For Cause 2:

  • Check if any of the Service Desk Canned Response Plugin modules is disabled in the Manage add-ons page by following the steps below:

    1. Choose

      (Auto-migrated image: description temporarily unavailable)

      >Add-ons > Manage add-ons

    2. Select "All add-ons" in the drop down menu located next to the search box

    3. Look for Service Desk Canned Response Plugin and expand it

    4. Click on the list of modules and check if any module is disabled (see example below):

      (Auto-migrated image: description temporarily unavailable)
  • If any of the module is disabled, click on the Enable button next to any of the disabled modules

For Cause 3:

  • Check if the Canned Response feature is disabled in the Dark Feature page by following the steps below:

    1. Go to the URL box in your browser and enter the following address: <hostname>/secure/admin/SiteDarkFeatures!Default.jspa (e.g. http://jira.examplecompany.com/secure/admin/SiteDarkFeatures!Default.jspa)

    2. Within Site Wide Dark Features check if sd.canned.responses.enabled is listed, as shown in the screenshot below:

      (Auto-migrated image: description temporarily unavailable)
  • If the feature is missing, add it by entering sd.canned.responses.enabled in the Enable dark feature box and clicking on the Add button, as shown below:

    (Auto-migrated image: description temporarily unavailable)

For Cause 4:

  • There has been a few reports of the ScriptRunner add-on preventing the Canned Response button from being displayed, especially if a version lower than 5.3.9 is installed. If you have ScriptRunner installed, try to follow either of the steps below and check if the canned response button comes back:

    • Disable the ScriptRunner add-on from the page

      (Auto-migrated image: description temporarily unavailable)

      >Add-ons > Manage add-ons

    • Or try to upgrade ScriptRunner to 5.3.9 or a higher version

For Cause 5:

Updated on April 8, 2025

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