Can not update Zephyr Plugin License.

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Trying to update license from Zephyr plugin License as below:

(Auto-migrated image: description temporarily unavailable)

results in an error and fails to update.

The following appears in the atlassian-jira.log

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 2016-05-21 22:07:05,679 Caesium-1-1 ERROR ServiceRunner [c.a.scheduler.core.JobLauncher] Scheduled job with ID 'CompatibilityPluginScheduler.JobId.Zephyr for JIRA background job' failed com.atlassian.jira.util.dbc.Assertions$NullArgumentException: clauseValue should not be null! at com.atlassian.jira.util.dbc.Assertions.notNull(Assertions.java:25) at com.atlassian.jira.jql.builder.DefaultJqlClauseBuilder.addStringCondition(DefaultJqlClauseBuilder.java:758) at com.atlassian.jira.jql.builder.DefaultJqlClauseBuilder.addStringCondition(DefaultJqlClauseBuilder.java:741) at com.atlassian.jira.jql.builder.DefaultJqlClauseBuilder.issueType(DefaultJqlClauseBuilder.java:232) at com.thed.zephyr.je.job.ZFJJobRunnerImpl.execute(ZFJJobRunnerImpl.java:60) at com.atlassian.scheduler.compat.clustered.ClusteredJobRunner.runJob(ClusteredJobRunner.java:54) at com.atlassian.scheduler.core.JobLauncher.runJob(JobLauncher.java:153) at com.atlassian.scheduler.core.JobLauncher.launchAndBuildResponse(JobLauncher.java:118) at com.atlassian.scheduler.core.JobLauncher.launch(JobLauncher.java:97) at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.launchJob(CaesiumSchedulerService.java:401) at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.executeClusteredJob(CaesiumSchedulerService.java:396) at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.executeQueuedJob(CaesiumSchedulerService.java:349) at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService$1.consume(CaesiumSchedulerService.java:255) at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService$1.consume(CaesiumSchedulerService.java:252) at com.atlassian.scheduler.caesium.impl.SchedulerQueueWorker.executeJob(SchedulerQueueWorker.java:65) at com.atlassian.scheduler.caesium.impl.SchedulerQueueWorker.executeNextJob(SchedulerQueueWorker.java:59) at com.atlassian.scheduler.caesium.impl.SchedulerQueueWorker.run(SchedulerQueueWorker.java:34) at java.lang.Thread.run(Thread.java:745) 2016-05-21 22:08:13,241 http-nio-7170-exec-23 ERROR admin 1328x529x1 1t6dg27 0:0:0:0:0:0:0:1 /secure/admin/ZUpdateLicense.jspa [c.t.z.j.config.action.ZephyrLicenseAction] LicenseKey is invalid. Please verify and re-enter correct LicenseKey!

Cause

The exact cause is not known, the error seems to be with the Zephyr client.

Workaround

The workaround is to update the license from manage-Add on as mentioned in the documentation How to Update Your Add-on License

Resolution

The workaround mentioned above is the solution for the moment.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.