Bulk Operations fail with a NullPointerException

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

When trying to bulk edit or transition issues in JIRA, the following NullPointerException is displayed on the screen, and the operation fails:

The following appears in the atlassian-jira.log:

1 2 3 4 5 java.lang.NullPointerException at com.atlassian.jira.bulkedit.operation.BulkWorkflowTransitionOperation.getActionDescriptor(BulkWorkflowTransitionOperation.java:146) at com.atlassian.jira.bulkedit.operation.BulkWorkflowTransitionOperation.perform(BulkWorkflowTransitionOperation.java:76) at com.atlassian.jira.web.action.issue.bulkedit.BulkWorkflowTransition.doPerform(BulkWorkflowTransition.java:219) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
1 2 3 4 5 java.lang.NullPointerException at com.intenso.jira.plugin.customfield.dynamicselect.DynamicSelectField.availableForBulkEdit(DynamicSelectField.java:151) at com.atlassian.jira.issue.fields.CustomFieldImpl.availableForBulkEdit(CustomFieldImpl.java:1636) at com.atlassian.jira.bulkedit.operation.BulkEditActionImpl.isAvailable(BulkEditActionImpl.java:36) at com.atlassian.jira.web.action.issue.bulkedit.BulkEdit.setFieldDefaults(BulkEdit.java:135)

Diagnosis

Try to execute the same operation with a different browser, running on private mode or with all add-ons disabled.

Cause

This is caused by third-party add-ons in the browser. Some of the plugins that are known to cause this issue:

  1. When using Google Chrome is the HTML Tag Checker plugin,

  2. When using the Dynamic Forms by InTENSO

It is possible other plugins might be causing the same issue.

Solution

Workaround

There are a couple of possibilities to workaround this issue:

  • Bulk transition/edit the issues using a different browser;

  • Disable all add-ons on the browser and try again;

  • Run the browser on private mode (which by default disable add-ons).

Updated on April 2, 2025

Still need help?

The Atlassian Community is here for you.