Base URL mismatches in UPM due to wrong port for HTTPS
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
The following appears in the atlassian-jira.log
:
1
2012-07-09 16:56:03,629 http-8080-3 WARN xxxx 1015x396x1 vj5zf 172.18.127.12,0:0:0:0:0:0:0:1 /rest/plugins/1.0/available/featured [upm.rest.async.AsynchronousTaskManager] Configured application base URL (https://xxx.xxx.xxx.xxx:334/jira) does not match base URL from request (https://xxx.xxx.xxx.xxx:443/jira)
Diagnosis
If your app base URL is HTTPS and doesn't explicitly specify a port, UPM wrongly displays a base URL mismatch warning because it thinks the port is supposed to be 334 instead of 443. This does not disrupt any UPM functionality, it just causes a misleading warning banner to appear all the time at the top of the UPM page.
Cause
This is caused by a bug in UPM 2.4. Please see UPM-2339 for more info.
Solution
Resolution
Upgrade to UPM 2.4.1. Please see Upgrading the Upgrading Universal Plugin Manager for more info.
Was this helpful?