Automation | The Due Date set by Automation rule which is copied from Sprint End date is different

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Automation rule to copy Sprint End Date to Issue Due Date sets incorrect Due Date

Environment

Jira Software Cloud

Diagnosis

  • Using Automation Rule when you try to set Due Date same as Sprint End Date it is different from the Sprint End Date set

  • Smart value {{issue.sprint.endDate.jiraDate}} is used to copy Sprint End date to issue Due date

  • Refer below example, Sprint End date is set as 3rd January however on the issue view we see the Due date copied as 2nd January

Sprint End date:

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Date set by automation:

(Auto-migrated image: description temporarily unavailable)

Cause

The Sprint dates are set according to the time zone configured at instance. However, when the automation rule updates the date, it will take the date according to the time zone of the user who executed/triggered the rule.

Solution

  • The smart value {{issue.sprint.endDate.jiraDate}} correctly captures the end date of the Sprint. However, the there's a difference in the dates depending on the time zone of your instance and the time zone selected under the rule executor user profile.

  • The timezone of instance can be edited under: https://domain.atlassian.net/jira/settings/system/general-configuration and users personal time zone preference can be edited under: https://id.atlassian.com/manage-profile/account-preferences

  • Make sure both the timezones are set the same or are in sync, and the rule will copy the same date as that of the set End date of the Active Sprint.

Updated on March 17, 2025

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