Automation Rule: Setting Issue Security Level fails
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
I created an automation rule, that is supposed to set the security level to 'external' after the issue is created.

This fails with the following error in the automation rules audit log:
1
No fields or field values to edit for issues (could be due to some field values not existing in a given project)

Environment
8.20.6
Cause
The problem is the actor does not have the right permission to set the security level.
Diagnose
Check the automation rule actor has the "Set Issue Security Permission" permission to set the issue security in the issue screen. We have a KB article to configure it: How to set the Security Level of an issue based on group membership
The actor was not added to the security level 'external' via Issue Security Level.
To verify this scenario, you can log in with the actor account and create a new issue in the affected project. The actor should be able to set an "external" security level from the issue screen. Otherwise, the automation will fail to execute to edit the issue security level values.
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