Fix Automation Rule Posting Private Comments in Jira Cloud
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Automation rules may post comments internally instead of publicly, even if set to "Share with customer." Ensure settings are correct.
Diagnosis
Once the automation rule has been triggered and marked as successful from your Automation Logs, the comment is posted as internal, and the portal-only customer users cannot view it from the Portal.
Cause
This is because the Actor of the Automation rule doesn't have access to the Jira Service Management product.
Solution
You can either change the rule's actor to an existing one with Jira Service Management access or add product access to the Actor.
Updated on May 12, 2025
Was this helpful?
Still need help?
The Atlassian Community is here for you.