Automation rule not triggered by field edit

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Automation rule is not being triggered by editing a specific field.

Cause

Automation rules match field names using a regular expression so if we have any special characters in the field that regular expressions need to handle differently like a parenthesis, for example, the rule is not triggered

Solution

Escape the special character when specifying the field name in the Automation Rule.

For example, if your field name is "Custom field (new)", we need to set the automation rule to look for "Custom field \(new\)"

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.