Automation rule doesn't assign any values to the Asset object custom field when triggered by the schedule

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

For Jira DC, the Branch on AQL is still not available: JIRAAUTOSERVER-544 - Insights Automation: Automation "Branch Rule" for Insight IQL results - Jira DC

A4J (Automation for Jira) rule does not assign any values to the Assets object field when triggered by the schedule.

Diagnosis

When the schedule triggers A4J and creates a new issue, it can't assign values to the Asset objects.

See the example below:

Create issue task in automation has value set for the Assets custom field.

The Asset custom field in this example is an Asset object custom field. The new issue is created with an empty Asset custom field.

Cause

The trigger for the A4J rule to assign value to the Assets object custom fields needs to be an issue or an object. The scheduled trigger does not meet these criteria.

Solution

Create a Global A4J rule with a Branch on AQL and trigger issue creation inside the branch.

See the example below:

Automation rule has the create issue action inside a 'For AQL' condition.
Create issue action should have a value for the Assets field like: "Name = {{object.name}}"
  • The {{object}} refers to the current object Asset object of the AQL branch.

  • If the AQL query returns several records, the rule will create several issues.

Please note that adding the Assets Object to its field at issue creation may not function due to a know Bug. See JSDCLOUD-10421 for a proposed workaround with the Edit Issue action.

After the Global A4J rule execution, the new issue is created with the filled Asset custom field.

Updated on March 14, 2025

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