Automation For Jira requesting license upgrade after Jira upgrade due to user count mismatch

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After upgrading Jira to a version where Automation for Jira plugin no longer requires a license, an App Notification with the message below is presented:

  • The app license for Automation for Jira needs an upgrade. You can upgrade to support more users and continue using the app.

Regarding Automation for Jira no longer requiring a license, more information can be found in the links below:

Environment

Reproduced in Jira 8.13.20 and Jira 9.0.0

Automation for Jira 8 or newer.

  • Note that A4J version 8 is bundled with Jira Data Center 9 and beyond.

  • A4Jversion 8 is free for Data Center instances, compatible with Jira 8.5+.

Diagnosis

You can validate if you have an old license by accessing the endpoint below (login on Jira beforehand and navigate to Manage Apps to prevent an error related to websudo):

  • <JIRA_BASE_URL>/rest/plugins/1.0/com.codebarrel.addons.automation-key/license

If you're affected by this, it will show the following message among other things:

error: "USER_MISMATCH",

That message indicates that the number of users for the plugin's license differs from Jira's license user count.

Cause

On previous versions of the plugin it required a license. If you upgrade the plugin itself to version 8+ or if you upgrade Jira to 9+, it will no longer require the license but that license will still be stored in the database.

If there's a discrepancy between the number of users for that old license and the number of users for your Jira Software/Jira Service Desk, the warning will be presented.

This is likely to follow an upgrade or downgrade in the numbers of users on your license.

Solution

If you see the "USER_MISMATCH" string above in the JSON output, you can delete the license using the rest endpoint below:

This has the same effect as manually removing the value provided for the license on the Manage Apps admin area. Since we don't have this option for A4J once it became a free app, we can use the REST API endpoint.

Replace "<username>" and "<password>" with an admin credentials.

1 curl -X DELETE -u <username>:<password> "<JIRA_BASE_URL>/rest/plugins/1.0/com.codebarrel.addons.automation-key/license"

This is a good output for that endpoint when you do not have a license associated to A4J:

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 { links: { license: "/rest/plugins/1.0/com.codebarrel.addons.automation-key/license", update-license: "/rest/plugins/1.0/com.codebarrel.addons.automation-key/license", self: "/rest/plugins/1.0/com.codebarrel.addons.automation-key/license", alternate: "/rest/plugins/1.0/com.codebarrel.addons.automation-key", validate-downgrade: "/rest/plugins/1.0/com.codebarrel.addons.automation-key/license/validate-downgrade", license-callback: "<JIRA_BASE_URL>/plugins/servlet/upm/license/com.codebarrel.addons.automation" }, pluginKey: "com.codebarrel.addons.automation", valid: false, active: false }

Updated on March 13, 2025

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