Atlassian Intelligence draft replies not working for Jira Service Management Cloud
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Using Atlassian Intelligence we can use draft replies, which will create responses based on the resolution provided in previous similar tickets that were resolved by agents.
However, when running the /draftreply
command, a response is not generated and the message pops up as below:
Atlassian Intelligence has no suggestions at this time. Feel free to try a different prompt or content.
Environment
Jira Service Management Cloud
Diagnosis
From your service project, go to Queues.
Open the issue view of a request.
Select Add internal note or Reply to customer.
Select Atlassian Intelligence from the toolbar, and then select Draft Reply. Alternatively, use
/ai
and then select Draft Reply. Or simply use/draftreply
.Atlassian Intelligence will generate a reply based on responses added by agents while resolving similar requests in the past. Atlassian Intelligence may not generate a reply if there are no other similar requests in the given service project.
In this scenario there are similar tickets but those tickets are not resolved and still open with multiple status.
Cause
The draft response are not generated due to the fact that there are no similar issues that are marked as "Resolved". To be able to generate the response, the similar tickets must be resolved. If they are in any other status, then the draft response will not be generated.
Solution
Close the existing similar ticket with a resolution and this would be considered by AI to generate the draft reply.
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