Assignee field of imported issues are set to unassigned after running project import

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

User runs the Project Import tool to import a project, and issues in that project all have the assignee field set to respective users. However, after the project import tool completes, the imported issues in the target instance have their assignee field set to "unassigned".

Diagnosis

  1. The log files show that the project import completes successfully without errors.

  2. Disabling third party plugins before performing the import does not help.

Cause

This is caused by the target instance project's issue-type Workflow containing a post-function called "The Assignee of The Issue Will Be Cleared" in the "Create Issue" transition.

Solution

Resolution

  • The best way to resolve this is to remove the post-function in the create issue transition of the workflow before starting the Project Import process.

  • You can re-add the post-function after the Project Import process completes.

Updated on April 8, 2025

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