Assets Discovery scans failed with "Method not found" exceptions

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Assets Discovery scans failed as many patterns could not be executed due to unmet system requirements.

Diagnosis

Exception below can be found in the Discovery scan log file in the logs folder

1 2 3 4 5 6 7 14/09/2021 23:23:51 : Using pattern: Windows_Hostinfo_Hostname_Model.pat (v4.0.0) 14/09/2021 23:23:51 : Error executing Pattern: Insight.Discovery.InfoClasses.ScanPattern 14/09/2021 23:23:51 : Exceptions: 14/09/2021 23:23:51 : Method not found: 'System.__Canon[] System.Array.Empty()'. at Insight.Discovery.ProviderClasses.AssemblyProvider.Invoke[T](String script, Object[] inputParams, Boolean& executeOk) at Insight.Discovery.ProviderClasses.AssetProviders.ProviderImplementation.WindowsHostProvider.GetGenericPatternInfo[TResult](ScanPatternType patternType, TResult result, ScanPattern pattern) in C:\SourceCode\discovery_repo\ProviderClasses\AssetProviders\ProviderImplementation\WindowsHostProvider.cs:line 233 ...

Cause

Some patterns failed to be executed due to one or more system requirements having not been met.

Solution

Ensure the system requirements are met. For example, Microsoft .Net Framework 4.7.2 or later must be installed on the supported version of Windows.

Other Notes

Discovery system requirements

Updated on February 26, 2025

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