'App version requires Jira 8.3 or later' error appears for beta participants

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

The Jira Data Center and Server mobile beta app shows the following error after being upgraded to version 1.x or later.

Thanks for trying our beta

You’re now using version 1.xx of the app, which requires Jira 8.3 or later.

The app will still work for now, but if you log out, you won’t be able to log back in. 

Cause

The Jira Data Center and Server mobile beta app was available to test with Jira 8.0, 8.1, and 8.2 (with some system add-on updates). The final app requires Jira 8.3 or later.

If you were previously using the beta app, and update it without upgrading Jira, the app will still work for a while, but you won't get access to new features. Also, once you log out, you won't be able to log back in, as the app checks that you have the required Jira version.

Resolution

To continue using the app you will need to upgrade your Jira instance to Jira 8.3 or later.

Not an admin? Send this page to your Jira administrator and ask them about their plans for upgrading Jira.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.