Agents receiving error Field 'duedate' cannot be set. It is not on the appropriate screen, or unknown.
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Agents are not able to create a ticket from Jira, and they are receiving the error Field 'duedate' cannot be set. It is not on the appropriate screen, or unknown.
Diagnosis
Agents can create tickets from the Customer Portal but receive errors only when they create tickets from Jira.
Cause
To set Due Date from Customer Portal during ticket creation , User should have Schedule Issues Permission.
To set Due Date from Jira during ticket creation, User should have Schedule Issues and Service Desk Agent Permission.
When using a custom Project Role for Agents or other users, then the Custom Project Role should have Service Desk Agent and Schedule Issues permission in order to set Due Date.
Solution
Jira administrators should grant Schedule Issues and Service Desk Agent Permission to Custom Project Role.
Please follow the below steps to add Schedule Issues and Service Desk Agent Permission to Custom Project Role in order to set Due Date.
Navigate to Project > Project Settings > Permissions
Click Actions > Edit Permissions > Grant Permission
Select Schedule Issues > Click Project Role > Select Custom Project Role > Click Grant
Click Actions > Edit Permissions > Grant Permission
Select Service Desk Agent> Click Project Role > Select Custom Project Role > Click Grant
For more details on Project Permission, refer to Manage project permissions
In case the issue is still not resolved, feel free to contact Atlassian support.
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