After upgrading to JIRA 7.0.9 (or above) the new application links diagnostics screen is not showing up

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

After upgrading/installing JIRA 7.0.9, users should see the new application link screen as per the release notes..

Still the old screen is showing up. There is no related error in the logs.

Cause

The new application link screen is present in JIRA 7.0.9 as a dark feature. If the dark feature is disabled, the new screen would not show up.

Resolution

  • Navigate to [JIRA Base url]/admin/SiteDarkFeatures!Default.jspa

  • Check if "applinks.v3.ui" is set to disabled

  • If its disabled, set it to enable.

This should bring back the new application link screen.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.