After upgrade to JIRA 6, user can't search issues and filters no longer work.
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
The following appears in the atlassian-jira.log
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2013-09-06 18:51:56,545 http-bio-8080-exec-36 ERROR xxxxxx 1131x2616x2 xxxxxx /rest/issueNav/1/issueTable [common.error.jersey.ThrowableExceptionMapper] Uncaught exception thrown by REST service
java.lang.NumberFormatException: null
at java.lang.Integer.parseInt(Unknown Source)
at java.lang.Integer.valueOf(Unknown Source)
at com.atlassian.jira.plugin.issuenav.service.issuetable.AbstractIssueTableCreator.getStableSearchResultsLimit(AbstractIssueTableCreator.java:381)
at com.atlassian.jira.plugin.issuenav.service.issuetable.AbstractIssueTableCreator.collectIssues(AbstractIssueTableCreator.java:156)
at com.atlassian.jira.plugin.issuenav.service.issuetable.AbstractIssueTableCreator.executeNormalSearch(AbstractIssueTableCreator.java:235)
Cause
The problem is cause by the jpm.xml or jira-config.properties file has been modified recently.
JRASERVER-33470 - NumberFormatException while accessing Issues page.
Resolution
Replace the jpm.xml file with the original file.
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