After logging in, the app displays a desktop version of Jira

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

This article only applies to Atlassian's server products. Learn more about the differences between cloud and server.

Problem

After logging in, the mobile app displays a desktop version of Jira.

Cause

The problem is caused by a proxy server filtering out some of the cookies required by the app. The mobile app uses a web view (loading the web login page within the app) to authenticate users, and then redirects them to the authenticated part of the app based on cookies returned in the response (authenticated=true). With cookies filtered out, the user can’t be redirected to the mobile view.

Solution

  1. Allowlist the following cookie on your proxy server. It can assume the true or false value.

    1 authenticated
  2. Make sure that the Jira mobile plugin is enabled, especially if you're using the skipInfo parameter in your MDM configuration. This problem can occur when skipInfo is set to true and the Jira mobile plugin is disabled.

Updated on April 15, 2025

Still need help?

The Atlassian Community is here for you.