After adding a new column it does not appear in the Jira issue navigator

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

After adding a new column in the issue navigator as per Configure the default issue navigator, it does not appear when performing a search.

Cause

This may be the expected behavior, as some custom fields are restricted to a certain Issue Type, or if they are project-specific as detailed in the troubleshooting section of Configure the default issue navigator.

Workaround

A successful workaround regarding this behaviour is using the '!=' argument on an unrelated issue-type. To do this:

  1. Identify an issue type not currently in use for your project, alternatively create a new issue-type for this specific purpose.

  2. Generate your original query using Advanced searching and add the following:

    1 issuetype != <issuetype not in use>

    ℹ️ The query results will contain the selected Issue Navigator custom-field column alongside all other issue types. This workaround also continues to work for the exporting of the document.

Resolution

  • Restrict your search.

  • Project-specific custom fields: The added column will appear if the search returns only issues that belong to that project.

  • Issue Type-specific custom fields: The added column will appear if the search returns only issues that belong to that issue type.

Updated on April 8, 2025

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