Administrator users from LDAP not able to create/edit filters or view avatars of other users

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Administrator users from LDAP directories are not able to create or edit filters in JIRA. They can search issues from the Issue Navigator but get error on saving the filter. They are also not able to view avatars of other users.

The following appears in Jira:

1 'xxx' does not have permission to access this page.

Cause

The JIRA administrator created by default has the JIRA Usersglobal permission (as it belongs to the group jira-users be default) which is currently not the case for the LDAP user accounts which is set to have only the JIRA Administrators privilege (which do not grant the jira-users group membership by default). Some JIRA operations require that the JIRA Users global permissions is available for the user. One such example is editing of issue filters. This operation will throw the permission error shown above for the users account that only have JIRA Administrators permission.

Resolution

Add the users to users to the JIRA Users Global Permission, which by default is the jira-users group.

ℹ️ Please see our Troubleshooting LDAP User Management documentation for further assistance with diagnosing LDAP problems.

Updated on April 8, 2025

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