Add Customers button is not displayed for the agents

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

The 'Add Customers' button is missing for agents.

Environment

Jira Service Management Cloud. 

Diagnosis

Agents would not be able to see 'Add Customers' button in the Customers section of the project. 

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Usually, this button would not be seen under the customer organization when the agents are not granted the Organization Management permission.

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But there would be a situation where agents would not be able to see this button from the 'Customers' section of the project. 

Cause

The issue is seen when the project role 'Service Desk Customers' is granted any of the project permissions. 

Solution

Remove the 'Service Desk Customers' role from the all project permission (Browse Projects, Assign Issues, etc).

Updated on March 18, 2025

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