AD Incremental sync fails with error: externalId attribute is not configured in directory

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Incremental sync fails with the following appearing in the atlassian-jira.log

1 2 2016-02-15 15:43:22,795 Caesium-1-2 ERROR ServiceRunner [c.a.crowd.directory.DbCachingRemoteDirectory] Incremental synchronisation for directory [ 10100 ] was unexpectedly interrupted, falling back to a full synchronisation com.atlassian.crowd.directory.ldap.cache.UsnChangedCacheRefresherIncSyncException: externalId attribute is not configured in directory.

Cause

The 'User Unique ID attribute' is not set in the AD directory's 'User Schema settings'.

Resolution

Set the User Unique ID attribute

  • Edit the affected Directory (Administration > User Management > User Directories)

  • Expand the User Schema settings section

  • Set the User Unique ID attribute (the default value for AD should be: objectGUID)

Updated on April 8, 2025

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