Actor permission error in automation execution log

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

The automation rule fails with the error message "Actor does not have permission to view the event that triggered this execution." and you can't identify the root cause.

Diagnosis

Automation manages rule execution with a processing queue, limiting parallel processing to maintain performance. If multiple rules share a trigger (e.g., Issue Created), they may not run simultaneously, delaying issue access for the automation rule actor.

Cause

The error message "Actor does not have permission to view the event that triggered this execution" is most often related to an issue ticket that was deleted by a different automation rule or manually deleted while the executed automation rule was in a queue to be processed.

On the Global Automation> Audit Logs page, you can identify/count how many rules are being executed for the same issue ticket; this will also help you find the automation rule that deleted the issue (if there are any using this action).

Solution

As possible solutions to avoid this error, you may consider one of the following:

  • Transition the issue ticket to a Closed/Canceled status rather than using the Delete Issue action.

  • Review the trigger for all automation rules executed for a single issue, and consider using Field value change as a trigger/action to cascade the execution rule if it is dependent. 

    • You can use the "Check to allow other rule actions to trigger this rule. Only enable this if you need this rule to execute in response to another rule" in the Rule Details.

  • See the Best practices for optimizing automation rules to improve your automation rules.

References

Updated on June 26, 2025

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