Accessing the View in Issue Navigator link on the Rapid Board causes a 404 Error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

This article deals with integration of JIRA with a proxy, as well as a third-party plugin. As such, it deals with procedures and products that are outside of the scope of Atlassian Support. This information is provided as a reference only.

Symptoms

When a user clicks on the View in Issue Navigator link in the Plan Mode of a GreenHopper Agile board, the browser is redirected to a 500 Error page, instead of the Issue Navigator.

1 http-bio-8080-exec-18518 ERROR username 467x682488x1 1bf0srb 192.168.0.100,127.0.0.1 /issues/ [jira.groovy.jql.AbstractScriptedJqlFunction] Function failed to execute http://jira.example.com/rest/greenhopper/1.0/rapidviews/list?query=Team+Planning - status code: 404

Diagnosis

This issue is seen when a proxy is in use

Cause

This issue is caused by proxy misconfiguration that disrupts the communication of REST calls back to the application

Solution

Resolution

  • Check your JIRA server's hosts file for any entry that refers to the JIRA server, localhost, or 127.0.0.1

  • Ensure your base URL agrees with the URL used to access JIRA

  • Ensure that your proxy is correctly configured

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.