Accessing Jira in the browser fails due to NS_ERROR_DOM_QUOTA_REACHED

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Accessing Jira results in the page not rendering correctly due to the below error.

The following appears in the browser:

1 2 3 4 5 6 7 8 9 10 11 Exception: NS_ERROR_DOM_QUOTA_REACHED: Persistent storage maximum size reached Resource: https://theavengers.example.com:8443/s/fd5d48367dd9c979d37b732e525ea1a0-CDN/en_USddtp8k/64019/30/845b63e07935e45f6071b79eea4b74f8/_/download/contextbatch/js/greenhopper-rapid-non-gadget,gh-rapid,atl.general,jira.project.sidebar,jira.global,jira.general/batch.js?locale=en-US&jag_disabled_marketing=true Line: 7808 Column: 0 Exception: NS_ERROR_DOM_QUOTA_REACHED: Persistent storage maximum size reached Resource: https://theavengers.example.com:8443/s/fd5d48367dd9c979d37b732e525ea1a0-CDN/en_USddtp8k/64019/30/845b63e07935e45f6071b79eea4b74f8/_/download/contextbatch/js/greenhopper-rapid-non-gadget,gh-rapid,atl.general,jira.project.sidebar,jira.global,jira.general/batch.js?locale=en-US&jag_disabled_marketing=true Line: 7808 Column: 0 Exception: NS_ERROR_DOM_QUOTA_REACHED: Persistent storage maximum size reached Resource: https://theavengers.example.com:8443/s/fd5d48367dd9c979d37b732e525ea1a0-CDN/en_USddtp8k/64019/30/845b63e07935e45f6071b79eea4b74f8/_/download/contextbatch/js/greenhopper-rapid-non-gadget,gh-rapid,atl.general,jira.project.sidebar,jira.global,jira.general/batch.js?locale=en-US&jag_disabled_marketing=true Line: 7808

Environment

  • Jira Data Center

  • The user is using Firefox

Cause

There is a limited amount of storage allocated within Firefox - by default this is 5mb. It can be easy to fill this storage up as it is stored on a domain level, rather than subdomain. This means if there are multiple subdomains that belong to the same domain, for example jira.example.com, confluence.example.com and stash.example.com they will all use that same storage space. This error is a result of it reaching capacity. A bug was raised with Mozilla to have this addressed, however it was resolved as Won't Fix - https://bugzilla.mozilla.org/show_bug.cgi?id=821659.

Workaround

Increasing the amount of storage in the browser is one possible approach to workaround this problem - this must be done by each user though. This can be with the below steps:

  1. Access about:config in the Firefox browser.

  2. Search for dom.storage.default_quota as below:

    (Auto-migrated image: description temporarily unavailable)
  3. Increase this value to something higher - for example 10240 (10mb).

  4. Attempt the action in Firefox again.

    1. If the problem is still present, a browser restart may be necessary.

ℹ️ There may be side effects to increasing the storage, for example additional memory use. This is not documented in http://kb.mozillazine.org/Dom.storage.default_quota however.

Updated on April 8, 2025

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