A board filter query is not accessible in the instance even with full permissions after migration

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

There was a cloud instance in which data was migrated to a new Data Center instance, the board filter query was not accessible even though administrator permissions were given. The following error message was appearing:

1 Field 'XXXXX' does not exist or you do not have permission to view it.
(Auto-migrated image: description temporarily unavailable)

Diagnosis

  • Validated the user does have permission to access the filter.

  • Verify the filter details to check for the permission that was configured before. In the filter details, it shows the "Hidden Project" instead of showing the actual project name:

    (Auto-migrated image: description temporarily unavailable)

Cause

  • For the "Hidden project", it could mean that you have no permission to access the project when the filter was initially configured.

  • Check the JQL query and find out that the Assign to[Dropdown] custom field is not a valid custom field.

Solution

  • Open the Details dialog, click on the "Edit Permissions" under "Hidden project" and remove the hidden project. Then, add a new project for example the related project to fix the errors. If you can't add the related project, please check if you have permission to access the related project. You can browse the Project if it's accessible on your side. If not, please check if you can grant yourself or user to access the related project via project settings > Permissions > look for the "Browse Project" permission.

  • Changing the custom field name in the filter to "Assign to" resolves the error, allowing the filter to work without any issues. ℹ️ The solution for changing the custom field name would be different depending on the JQL query in the board filter.

Updated on April 8, 2025

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