500 error due to corrupted field configuration scheme entries

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

This error may be encountered during a variety of scenarios such as:

  • After issue creation.

  • After logging in.

  • When accessing a field configuration scheme.

The following stack trace appears in the 500 error page:

1 2 3 4 5 6 7 8 9 10 11 12 13 14 Technical details Log's referral number: 3026196e-74f2-43ee-8f9a-f9cf3c66460d Cause Referer URL: http://localhost:8080/secure/CreateIssue.jspa com.atlassian.cache.CacheException: java.lang.NullPointerException com.atlassian.cache.CacheException: java.lang.NullPointerException at com.atlassian.cache.memory.DelegatingCache.get(DelegatingCache.java:67) at com.atlassian.jira.issue.fields.config.persistence.CachedFieldConfigSchemePersister.getFieldConfigScheme(CachedFieldConfigSchemePersister.java:89) at com.atlassian.jira.issue.fields.config.manager.FieldConfigSchemeManagerImpl.getValue(FieldConfigSchemeManagerImpl.java:72) at com.atlassian.jira.issue.fields.config.manager.FieldConfigSchemeManagerImpl.getValue(FieldConfigSchemeManagerImpl.java:63) at com.atlassian.jira.issue.fields.config.manager.FieldConfigSchemeManagerImpl.getRelevantConfigScheme(FieldConfigSchemeManagerImpl.java:322) at com.atlassian.jira.issue.fields.config.manager.FieldConfigSchemeManagerImpl.getRelevantConfig(FieldConfigSchemeManagerImpl.java:292) at com.atlassian.jira.issue.fields.CustomFieldImpl.getRelevantConfig(CustomFieldImpl.java:649) at com.atlassian.jira.issue.fields.CustomFieldImpl.isInScope(CustomFieldImpl.java:312)

Cause

The problem occurs when the global context does not have a field configuration ID that matches a custom field configuration schemes. It is not yet known what causes this situation.

You can verify that you have this problem by running this SQL command:

1 2 3 4 SELECT * FROM configurationcontext WHERE fieldconfigscheme NOT IN (SELECT ID FROM fieldconfigscheme);

Resolution

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

1. Create a backup copy of your JIRA database and your JIRA Home directory.

2. Shutdown JIRA.

3. Verify that you have this problem using the SQL command above. If you find any orphaned field configuration contexts you can delete them with the following query:

1 2 3 4 DELETE FROM configurationcontext WHERE fieldconfigscheme NOT IN (SELECT ID FROM fieldconfigscheme);

4. Start JIRA and perform a full full re-index.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.