'452 4.3.1 Insufficient system resources' observed in Jira when using MS Exchange

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptom

Notification emails fail with a "Too many recipients" exception, observed in the outgoing-mail.log:

1 com.atlassian.mail.MailException: com.sun.mail.smtp.SMTPSendFailedException: 452 4.3.1 Insufficient system resources

Causes

This error code is coming from the MS Exchange SMTP server rather than Jira or Java Mail. This indicates a lack of resources on the MS exchange mail server. Check that there is sufficient disk space and memory on the MS Exchange server.

Diagnosis

Enable mail protocol logging to determine if the 452 error codes are appearing in the log entry.

Resolution

Free up disk space or allocate additional memory in the MS Exchange Server that Jira is connecting to.

Updated on April 8, 2025

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