Work Items created in Jira Align do not sync back to Jira

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When a Work Item is created in Jira, it is also created in Jira Align after sync. However, if a Work Item is created in Jira Align, it is not created in Jira after sync.

Diagnosis

Even when Bidirectional sync is enabled under Jira Settings, issues created in JiraAlign don't sync to Jira, with the error "400:Bad Request, reporter: Field 'reporter' can't be set. It is not on the appropriate screen or unknown."

Cause

The Service user used to setup Connector does not have the "Modify Reporter" permission for the Reporter field in Jira.

Solution

  • Login to Jira Instance, using the Service Account

  • Access the project

  • Go to Project settings → Permissions

  • Add permission for the user to be able to "Modify Reporter" permission

Updated on March 13, 2025

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