Message Cannot open server 'XXXXX' requested by the login in Jira Align Enterprise Insights

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Some connections trigger an error describing that it can’t open server XXXX, which was requested by the login.

This error appears in any tool that tries to connect to Enterprise Insights throughout Microsoft SQL Server Management Studio, Azure Data Studio, Tableau, PowerBI, etc.

Diagnosis

The error can be observed in any tool that tries to log into Enterprise Insights. A message like “Cannot open server 'XXXXXX' requested by the login.” followed by “Client with IP address 'XXX.XX.XX.XX' is not allowed to access the server. To enable access, use the Windows Azure Management Portal or run sp_set_firewall_rule on the master database to create a firewall rule for this IP address or address range.

Cause

That error message indicates that the IP address 'XXX.XX.XX.XX' is not currently authorized to access the Enterprise Insights server, pointed to the customer’s instance. This can occur due to firewall settings in Azure that restrict which IP addresses can access specific servers for security purposes, which is enabled for all Production EI environments.

Below we can check the EI architecture and how the Firewall is allocated to protect the access to the EI databases.

Firewall is in place when accessing the database.

It is worth mentioning that it is common that connections are over the public internet using TCP 1433. All server firewalls are set to require TLS > 1.2 encryption on any connection.

Solution

To resolve this issue, a new firewall rule needs to be created, allowing this IP address to access the server.

How to do that will depend on the installation of the Enterprise Insights.

For Enterprise Insights on Cloud

Open a Support Ticket to Jira Align indicating the error message and the public IP from the environment that is receiving this ticket.

This situation will be handled by the Jira Align Support team.

For Enterprise Insights on Data Center

  • The Sysadmin will need to create a new firewall rule that allows this IP address to access the server.

    • It can be manually on the customer’s network firewall and extended to the SQL Server.

OR

  • Using the sp_set_firewall_rule on the EI instance database, described as “Customer_DW”

    • For that, there is an SQL stored procedure that the sysadmin can run to create a new firewall rule. The general syntax is:

      1 EXECUTE sp_set_firewall_rule N'<Firewall Rule Name>', '<Start IP Address>', '<End IP Address>'
    • After running this command, the IP address passed there should be allowed to access the EI server. Remember to replace <Firewall Rule Name> with a name that makes sense for the users.

Updated on April 14, 2025

Still need help?

The Atlassian Community is here for you.