Jira Align Enterprise Insights Self-Hosted ETL job stops to run
Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
The ETL job stops running and there is no error logged on the Job Monitor, which can be found on Integration Services Catalog > SSISDB > Jira Align ETL > right click > Reports > Standard Reports > All Executions.
Diagnosis
Check Event Viewer and see if the error below is present:
Could not allocate space for object 'internal.operations'.'IX_Operations_object_id' in database 'SSISDB' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.
Cause
The DB can’t allocate more space for the filegroup, so it can’t run.
Solution
The option of autogrowth needs to be enabled on the DB. To do that:
Go to the SQL Manager > right-click on the EI DB > Properties
On the Files option, adjust the autogrowth through the ellipses (setting it to the values needed or unlimited)
Do the same on the “FileGroups" option
Notice that this way, the DB will continues to increase the size of the data file, until everything is consumed, so the DBAs need to keep an eye on it and act accordingly to prevent problems
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