Jira Align Enterprise Insights connectivity issues via Azure Data Studio

Summary

End users are unable to connect Enterprise Insights via the Azure Data Studio tool even with a correct user account and allowed IP addresses configured in EI.

Diagnosis

  • The user IPs are whitelisted.

  • No Firewall issues.

  • SQL Username/password works.

  • Telnet to database port 1433 works

  • Tableau tool access works via SQL auth.

  • However, theusers are still unable to access the EI via Azure Data Studio due to the timeout error below. Connections failed.

Error received:

Microsoft.Data.SqlClient.SqlException (0x80131904): Connection Timeout Expired. The timeout period elapsed while attempting to consume the pre-login handshake acknowledgement. This could be because the pre-login handshake failed or the server was unable to respond back in time.

Cause

Checking internally, the packets used on the end-user connections are still attempting to master the db which is not correct. Instead, connection attempts should be against customerDBName_DW.

  • Connection type = Microsoft SQL Server

  • Server = Server name

  • Authentication type = SQL Login

  • User name = User name for your Enterprise Insights instance (Provided by Atlassian)

  • Password = Password associated with user name (Provided by Atlassian)

  • Remember password = Select the checkbox

  • Database = customerDBName_DW

  • In the advanced tab set Encrypt = True to enable SSL encryption

Solution

You need to delete all Azure Data Studio tool connection cache and re-create again. It seems there is a bug on the Azure DS tool that ignores some fields, such as Database, which causes connection attempts to be done towards the master server.

Updated on April 14, 2025

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