Jira Align Connector button missing for some users
Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When checking the Admin > Jira Setup, the Jira Connector button is not present on the screen.
Diagnosis
When going to the Admin > Jira Setup, the Jira connector button is not present on the screen, just the name of the current connector.
Cause
There are 2 possible causes for this problem:
The default configuration for the roles under Admin > Roles > [Role] > Administration > Jira Settings, is marked as Read-Only.
On the Connector settings panel, there are users on the 'Admin' field, and in this case, only they will have access to the button.
Solution
For scenario 1 above, the fix is to remove the Read-Only, under the Role > Administration > Jira Settings, save the role, and ask the user to log out/log in
For scenario 2, the person can be added as an Admin OR remove all the Admin (if left blank, everyone with the right permission can see the button)
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