How to restore items that are stuck or missing from the recycle bin in Jira Align
Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Occasionally, there may be work items that have been deleted but do not show up in the recycle bin. This doesn't happen often and usually doesn't cause a problem. However, there can be circumstances where it can cause issues - such as trying to delete a Program that is tied to the hidden items. The "phantom" work items that are associated with a Program can prevent it from being deleted.
Diagnosis
If you receive an error message about a particular issue ID but are unable to access it in the UI or locate it in the recycled/cancelled bin
Cause
A rare issue can sometimes cause work items deleted from the recycle bin to not be properly deleted.
Solution
Since the affected work items cannot be accessed in the UI, you must use the API to restore the items. Using the PUT restore function on the work item type endpoint will restore the item and make it visible in the UI once again. Endpoint example below for stories. The same restore function exists on all other work item type endpoints (Features, Epics, etc.)
PUT
/align/api/2/Stories/{id}/restore
Simply replace the {id} of the API request with the work item ID. Once the item has been restored, it should be visible again in the UI where you can either keep or permanently delete as needed.
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