Feature Product Field in Jira Align clears after Connector Sync

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Summary

This article is intended to fix the issue whereby the Jira connector resets the Feature’s Product field in Jira Align after the connector sync.

Diagnosis

This article is intended to fix the issue whereby the Jira connector resets the Feature’s Product field in Jira Align after the connector sync and no errors are captured in the JA feature’s audit log nor in Splunk.

Cause

When you have Jira Align Admin > Jira Settings > Jira Setup > Feature Product configured to use a Custom Field ID the Product sync becomes Bi-Directional. And, if you don't have all the Jira Products mapped in Jira Align Admin > Jira Settings > Jira Setup > Product custom field > Manage > Sync Jira Products, the connector resets the Feature’s Product field.

Solution

  1. In Jira, navigate to issues > Custom Fields.

  2. Search for the custom field "Product”> Click the ellipsis button > Context and Default values.

  3. The Field type must be "Select Single Choice"

  4. Make sure all the products found in Jira match products in JA and the sync should successfully occur.

To prevent typos and errors when the user is comparing products in Jira x JA, another way to capture the list of products available in JA and Jira is by running a GET API call to return the values.

Jira API call:

1 https://<jira-url>/rest/api/2/issue/<issue-key>/editmeta

Jira Align API call:

1 https://<jira-align>.jiraalign.com/rest/align/api/2/Products

Updated on April 14, 2025

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