Error "User cannot be assigned issues" on Jira Align Connector

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

This article aims to resolve a problem whereby whenever customers try assigning an issue to someone in Jira, they get the following error message:

“User 'xxxxxxxxxxx' cannot be assigned issues.”

Diagnosis

Error “User 'xxxxxxx' cannot be assigned issues.” in the Jira Align > Jira Change Logs.

Cause

This error can be triggered for different reasons:

  • The user doesn't have the permissions to be assigned issues (Service Desk Agent and Assignable user permissions).

  • The user does not have a Jira Service Management license.

If neither seems to be the case, another possibility is:

  • The account you are trying to assign the issue is a portal-only customer account.

Solution

So based on the error message and replication of the issue in our test environment, the likely cause of the issue is that user(s) don't have the (Assignable user permissions) permissions in Jira to be assigned issues.

You can use the Jira Permission helper to check the users' permission.

  1. Go to Settings > System > Permission Helper.

  2. Fill out the form with the user, issue key, and permission "Assignable user".

  3. Submit.

The results should let you know if the users are in the correct roles to have this permission.

Updated on April 14, 2025

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