Component name errors while scanning boards using JET apps
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Summary
Scanning boards in Jira using JET apps returns "The value <component_name> does not exist for the field 'component'” error.
Cause
JQL filter contains an old value of the component.
Step to reproduce
Define a component ‘fedecomponent’ in a board for example in Settings project → issues → components

Define a JQL in the “Edit filter Query“ like this for example where the component is mentioned.
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project in (FED, FD) AND component in (fedecomponent) ORDER BY Rank ASC

Add the value “fedecomponent” to an issue

Run the JET apps scanning the board of the project with this component, and the error does not appear.
Edit the component in ‘Settings project → issues → components’ changing value from “fedecomponent” to “fedecomponent1“

Run the JET apps scanning the board of the project with this competent, and the error will appear.
The issue will have the component field with value renamed with “fedecomponent1“.
The JQL in “Edit filter Query“ is not updated with the new value of the component “fedecomponent1“ but will be still like this and this causes the issue in JET when the board is scanned and the same error is shown if you run the JQL in search of Jira
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project in (FED, FD) AND component in (fedecomponent) ORDER BY Rank ASC
Solution
Modify the JQL with the new value of the component, in this example, it should be as mentioned below, and then the JET does not return this error:
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project in (FED, FD) AND component in (fedecomponent1) ORDER BY Rank ASC
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