Clicking 'Request Jira for access' button during Connector setup in Jira Align returns "token expired" message

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When setting up the Jira Connector in Jira Align according to guide Jira Align Cloud to Jira Data Center Connectivity (Quick Guide), performing step 18 and clicking the 'Request Jira for access' button returns error:

“The request token you are trying to authorize has expired. Please try another token.“

Diagnosis

When clicking 'Request Jira for access' button, the following error is observed:

Welcome to JIRA The request token you are trying to authorize has expired. Please try another token. (Close this dialogue, then go back to the site requesting access and tell it to try again.)

Cause

The OAuth token has expired or does not exist.

Solution

  1. Click the 'Restart Jira OAuth access' button.

  2. Repeat steps 17-21 from guide Jira Align Cloud to Jira Data Center Connectivity (Quick Guide) to reauthorize OAuth access with a freshly generated token.

Updated on March 14, 2025

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