Can't see users when editing assignee in Jira cloud even with permissions
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
A user can't see or add another user to the assignee field of work items in Jira Cloud projects.
Diagnosis
Steps from the documentation Jira user can't see or search others in user-picker fields like Assignee have already been followed:
The affected user has the Browse users and groups global permission
The user that is supposed to be assigned has the Assignable user permission
Cause
Jira's database is out of sync, or indexing is required. This can be caused when a Jira userbase is particularly large, or has undergone significant additions during a Cloud migration.
Solution
Manually remove and re-add the user to the Jira default group
Removing and re-adding the user triggers a sync manually, which resolves the issue.
Navigate to admin.atlassian.com
Identify the Jira default group
Search for the user under the Users section
Remove the user from the default access group
Re-add the user to the default access group
This process will trigger a sync. Within a few minutes, the sync will complete, and the issue should resolve.
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