Search or View Issues Cause System Error

プラットフォームについて: Data Center のみ。 - This article only applies to Atlassian apps on the Data Center プラットフォーム

この KB は Data Center バージョンの製品用に作成されています。Data Center 固有ではない機能の Data Center KB は、製品のサーバー バージョンでも動作する可能性はありますが、テストは行われていません。 Server* 製品のサポートは 2024 年 2 月 15 日に終了しました。Server 製品を実行している場合は、 アトラシアン Server サポート終了 のお知らせにアクセスして、移行オプションを確認してください。

*Fisheye および Crucible は除く

症状

Trying to search or view issues results in a System Error. The following appears in the atlassian-jira.log:

java.lang.NullPointerException at com.atlassian.jira.security.type.GroupCF.getQueryForGroupName(GroupCF.java:105) at com.atlassian.jira.security.type.GroupCF.getQueryForGroups(GroupCF.java:97) at com.atlassian.jira.security.type.GroupCF.getQueryForSecurityLevel(GroupCF.java:124) at com.atlassian.jira.security.type.AbstractIssueFieldSecurityType.getQuery(AbstractIssueFieldSecurityType.java:73) at com.atlassian.jira.security.type.GroupCF.getQuery(GroupCF.java:68) at com.atlassian.jira.security.type.AbstractIssueFieldSecurityType.getQuery(AbstractIssueFieldSecurityType.java:95)

原因

There is an error with the issue security scheme permissions returning null value.

ソリューション

  1. 移動 Administration > Issues > Issue Security Schemes

  2. Check the Security Levels and remove any users/groups that do not actually exist in the system. Also, remove any User Custom Fields, or Group Custom Fields that do not actually exist in the system.

更新日時: September 25, 2025

さらにヘルプが必要ですか?

アトラシアン コミュニティをご利用ください。