Layout problems due to a cookie size after installation of third party SSO

プラットフォームについて: Data Center のみ。 - This article only applies to Atlassian apps on the Data Center プラットフォーム

この KB は Data Center バージョンの製品用に作成されています。Data Center 固有ではない機能の Data Center KB は、製品のサーバー バージョンでも動作する可能性はありますが、テストは行われていません。 Server* 製品のサポートは 2024 年 2 月 15 日に終了しました。Server 製品を実行している場合は、 アトラシアン Server サポート終了 のお知らせにアクセスして、移行オプションを確認してください。

*Fisheye および Crucible は除く

要約

問題

Browsing through the UI after installing third-party SAML SSO for JIRA display problem will be visible.

診断

環境

診断ステップ

  • Checking the HAR file 400 errors will be visible.

    400 Bad Request

    If you receive this error frequently, the best thing to do is to delete the Cookies for that particular domain. Let us say, if you are receiving this error when you visit any page on say, example.com, then you should delete all the Cookies of example.com from your browser’s cache.

    (自動移行された画像: 説明は一時的に利用できません)

原因

Header size is too big for certain requests. Increasing the value on Tomcat should help in this case.

ソリューション

ソリューション

Increase or add "maxHttpHeaderSize" size to "16000" in used connector in the <Jira-install>/conf/server.xml like this:

From

<Connector port="8090" connectionTimeout="20000" maxThreads="200" minSpareThreads="10" enableLookups="false" acceptCount="10" URIEncoding="UTF-8" />

宛先

<Connector port="8090" connectionTimeout="20000" maxThreads="200" minSpareThreads="10" enableLookups="false" acceptCount="10" URIEncoding="UTF-8" maxHttpHeaderSize="16000"/>
更新日時: September 26, 2025

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