Invalid message with signature 18245 is thrown when JIRA applications are behind Apache

プラットフォームについて: Data Center のみ。 - This article only applies to Atlassian apps on the Data Center プラットフォーム

この KB は Data Center バージョンの製品用に作成されています。Data Center 固有ではない機能の Data Center KB は、製品のサーバー バージョンでも動作する可能性はありますが、テストは行われていません。 Server* 製品のサポートは 2024 年 2 月 15 日に終了しました。Server 製品を実行している場合は、 アトラシアン Server サポート終了 のお知らせにアクセスして、移行オプションを確認してください。

*Fisheye および Crucible は除く

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症状

JIRA applications are configured behind Apache using AJP protocol and the following appears in the application server log files (UNIX: $JIRA_INSTALL/logs/catalina.out, or Windows: $JIRA_INSTALL/logs/stdout and stderr):

Nov 26, 2013 12:09:51 PM org.apache.coyote.ajp.AjpMessage processHeader SEVERE: Invalid message received with signature 18245 Nov 26, 2013 12:09:51 PM org.apache.coyote.ajp.AjpMessage processHeader SEVERE: Invalid message received with signature 18245

Also, the following appears on the browser screen:

(自動移行された画像: 説明は一時的に利用できません)

原因

This error is caused by incorrect Apache configuration. This is usually related to the VirtualHost configuration section in Apache httpd.conf file.

ソリューション

Make sure that the following is inside the VirtualHost, replacing jiraserver with the hostname of the JIRA application server and also modifying the context path accordingly (/issues).

ProxyRequests Off ProxyPass /issues ajp://jiraserver:8009/issues ProxyPassReverse /issues ajp://jiraserver:8009/issues
更新日時: September 25, 2025

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