International Characters in Notification Email Subject Lines Are Being Replaced with Question Mark

プラットフォームについて: Data Center のみ。 - This article only applies to Atlassian apps on the Data Center プラットフォーム

この KB は Data Center バージョンの製品用に作成されています。Data Center 固有ではない機能の Data Center KB は、製品のサーバー バージョンでも動作する可能性はありますが、テストは行われていません。 Server* 製品のサポートは 2024 年 2 月 15 日に終了しました。Server 製品を実行している場合は、 アトラシアン Server サポート終了 のお知らせにアクセスして、移行オプションを確認してください。

*Fisheye および Crucible は除く

症状

Japanese characters displayed as '?' in email, even though the equivalent text is displayed correctly in the web User Interface.

原因

The ISO-2022-JP encoding cannot encode all the Japanese Kanji characters. For example, the characters "①~⑳髙㌔㌢㍍㍍㊤㊥㊦㊧㊨㈱㈲㈹㍾㍽㍼㍻" cannot be encoded correctly.

When trying to send the e-mail JIRA converts characters than cannot be encoded into ISO-2022-JP as '?'

ソリューション

Change the mail encoding to UTF-8 or another encoding that can represent all characters. To do this, set the system property JAVA_OPTS=-Dfile.encoding=utf-8. See Setting Properties and Options on Startup for instructions.

更新日時: September 25, 2025

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