Cannot Login to JIRA after Upgrade due to Null Pointer Exception

プラットフォームについて: Data Center のみ。 - This article only applies to Atlassian apps on the Data Center プラットフォーム

この KB は Data Center バージョンの製品用に作成されています。Data Center 固有ではない機能の Data Center KB は、製品のサーバー バージョンでも動作する可能性はありますが、テストは行われていません。 Server* 製品のサポートは 2024 年 2 月 15 日に終了しました。Server 製品を実行している場合は、 アトラシアン Server サポート終了 のお知らせにアクセスして、移行オプションを確認してください。

*Fisheye および Crucible は除く

要約

症状

At the 96% mark of an otherwise successful upgrade, the upgrade is interrupted and the following is seen in the browser:

A system error has occurred. If this problem persists, please contact your JIRA administrators. Otherwise, please create a support issue on our support system at http://support.atlassian.com with the following information: a description of your problem cut & paste the error and system information found below Cause: java.lang.NullPointerException Stack Trace: [hide] java.lang.NullPointerException at com.atlassian.crowd.embedded.core.CrowdDirectoryServiceImpl.storeLdapConnectionPoolConfiguration(CrowdDirectoryServiceImpl.java:308) at com.atlassian.crowd.embedded.core.CrowdDirectoryServiceImpl.initialiseConnectionPoolSystemProperties(CrowdDirectoryServiceImpl.java:291) at com.atlassian.crowd.embedded.core.CrowdDirectoryServiceImpl.getApplication(CrowdDirectoryServiceImpl.java:263) at com.atlassian.crowd.embedded.core.CrowdDirectoryServiceImpl.findAllDirectories(CrowdDirectoryServiceImpl.java:81) at com.atlassian.jira.user.util.DefaultUserManager.getWritableDirectories(DefaultUserManager.java:261) at com.atlassian.jira.user.util.DefaultUserManager.hasPasswordWritableDirectory(DefaultUserManager.java:277)

診断

This is seen when the restore includes the osuser.xml file, but the External User Management flag is not set to True.

原因

This is caused by the absence of an Internal directory configuration in the osuser.xml file.

ソリューション

ソリューション

  1. Remove the osuser.xml file.

  2. Jira を再起動します。

更新日時: September 26, 2025

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