CommitException when trying to connect to Perforce server

プラットフォームについて: Data Center のみ。 - This article only applies to Atlassian apps on the Data Center プラットフォーム

この KB は Data Center バージョンの製品用に作成されています。Data Center 固有ではない機能の Data Center KB は、製品のサーバー バージョンでも動作する可能性はありますが、テストは行われていません。 Server* 製品のサポートは 2024 年 2 月 15 日に終了しました。Server 製品を実行している場合は、 アトラシアン Server サポート終了 のお知らせにアクセスして、移行オプションを確認してください。

*Fisheye および Crucible は除く

症状

When trying to connect to my Perforce Server, the following exception occurs:

com.perforce.api.CommitException java.io.IOException: Perforce client error: Connect to server failed; check $P4PORT. TCP connect to 192.168.0.79:2128 failed. connect: 192.168.0.79:2128: WSAETIMEDOUT

原因

Your Perforce server is slow to respond and has timed out.

ソリューション

Check that you can access it remotely from the command-line using p4. Ensure that the port that your Perforce server is running on is not blocked by your firewall or anti-virus software.

Search the Perforce troubleshooting documentation for the error code WSAETIMEDOUT for more possible solutions.

更新日時: September 25, 2025

さらにヘルプが必要ですか?

アトラシアン コミュニティをご利用ください。