Users is not longer able to access previously subscribed Team Calendars
プラットフォームについて: Data Center のみ。 - This article only applies to Atlassian apps on the Data Center プラットフォーム。
この KB は Data Center バージョンの製品用に作成されています。Data Center 固有ではない機能の Data Center KB は、製品のサーバー バージョンでも動作する可能性はありますが、テストは行われていません。 Server* 製品のサポートは 2024 年 2 月 15 日に終了しました。Server 製品を実行している場合は、 アトラシアン Server サポート終了 のお知らせにアクセスして、移行オプションを確認してください。
*Fisheye および Crucible は除く
問題
Users who were subscribed to a team calendar were able to view the calendar without any problems.
atlassian-confluence.log file you can observer NullPointerException as the one below:
2015-10-09 09:28:27,112 ERROR [http-nio-8090-exec-4] [common.error.jersey.ThrowableExceptionMapper] toResponse Uncaught exception thrown by REST service: null
-- referer: http://localhost:8090/confluence/calendar/mycalendar.action | url: /confluence/rest/calendar-services/1.0/calendar/events.json | userName: testa
java.lang.NullPointerException
at com.atlassian.confluence.extra.calendar3.calendarstore.DelegatingCalendarDataStore.getEventEditUserRestrictions(DelegatingCalendarDataStore.java:392)
at com.atlassian.confluence.extra.calendar3.DefaultCalendarPermissionManager.getEventEditUserRestrictions(DefaultCalendarPermissionManager.java:65)
at sun.reflect.GeneratedMethodAccessor1224.invoke(Unknown Source)
...
...原因
Space Permissions or Calendar Restrictions have changed.
ソリューション
Review and fix the space permission of the affected calendar, and check that no new restrictions have been applied to the calendar. If they have changed, you will need to revert the change.
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