Unable to install plugins using MS SQL due to transaction log exceptions

プラットフォームについて: Data Center のみ。 - This article only applies to Atlassian apps on the Data Center プラットフォーム

この KB は Data Center バージョンの製品用に作成されています。Data Center 固有ではない機能の Data Center KB は、製品のサーバー バージョンでも動作する可能性はありますが、テストは行われていません。 Server* 製品のサポートは 2024 年 2 月 15 日に終了しました。Server 製品を実行している場合は、 アトラシアン Server サポート終了 のお知らせにアクセスして、移行オプションを確認してください。

*Fisheye および Crucible は除く

問題

When attempting to install Confluence plugins while using MS SQL you may receive this error in atlassian-confluence.log:

Caused by: java.sql.SQLException: The transaction log for database 'confluence' is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases

原因

The transaction log is set at a specific size and is unable to expand as needed.

ソリューション

Setting the transaction log to have an auto-growth option instead of 'NONE' should resolve the issue. You may also need to set a larger initial size.  Please see this support article from Microsoft for more information on tweaking this setting.

更新日時: September 25, 2025

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