Unable to Complete Installation Due to File Permissions
プラットフォームについて: Data Center のみ。 - This article only applies to Atlassian apps on the Data Center プラットフォーム。
この KB は Data Center バージョンの製品用に作成されています。Data Center 固有ではない機能の Data Center KB は、製品のサーバー バージョンでも動作する可能性はありますが、テストは行われていません。 Server* 製品のサポートは 2024 年 2 月 15 日に終了しました。Server 製品を実行している場合は、 アトラシアン Server サポート終了 のお知らせにアクセスして、移行オプションを確認してください。
*Fisheye および Crucible は除く
症状
Installing Confluence fails with an error similar to following which appears in the atlassian-confluence.log file.
2007-09-20 14:18:36,975 ERROR [http-80-Processor23] [opensymphony.webwork.dispatcher.ServletDispatcher] serviceAction Could not execute action
-- url: /confluence/setup/dosetuplicense.action | userName: anonymous
com.atlassian.config.ConfigurationException: Couldn't save confluence.cfg.xml to /var/lib/confluence directory.
...
Caused by: java.io.IOException: Permission denied
at java.io.File.createNewFile(File.java:876)
原因
This occurs when the operating system user running Confluence has inadequate write permissions to the Confluence home directory (in this example '/var/lib/confluence')
ソリューション
Ensure that the operating system user running Confluence has full read/write permissions to the Confluence home directory
この内容はお役に立ちましたか?